Kurzinfo CB-K09/0254

3 Risiko: mittel
Information zu Schwachstellen und Sicherheitslücken
Titel: Mehrere Schwachstellen in 'Subversion' ermöglichen Codeausführung
Datum: 07.08.2009
Software: Subversion Client und Server <= 1.5.6, Subversion Client und Server 1.6.0 bis 1.6.3 einschließlich
Plattform: Unix, Linux, Microsoft Windows
Auswirkung: Ausführen beliebigen Programmcodes
Remoteangriff: Ja
Risiko: mittel
Bezug: Subversion Sicherheitsmeldung
Beschreibung

Die Versionsverwaltung Subversion weist mehrere heapbasierte Pufferüberlauf-Schwachstellen in der Client- und Server-Komponente auf, die auf die libsvn_delta- (CVE-2009-2411) und APR-Bibliothek (CVE-2009-2412) zurückzuführen sind. Ein entfernter Angreifer kann die Schwachstellen ausnutzen, um beliebigen Code im Kontext der Anwendung auf dem Client oder dem Server auszuführen. Fehlgeschlagene Angriffe können zu einem Denial-of-Service der Anwendung führen.

Die Subversion-Entwickler stellen Patches zur Behebung der Schwachstellen bereit [1]. Aktualisierte Pakete diverser Linux-Distributionen dürften in Kürze folgen. Weitere Informationen entnehmen Sie bitte folgenden Quellen:

  1. Subversion Sicherheitsmeldung

  2. Secunia

CERT-Bund bietet personalisierte Warn- und Informationsdienste an.
Bitte registrieren Sie sich, um diese Angebote nutzen zu können.