Kurzinfo CB-K16/0358 Update 1

2 Risiko: niedrig
Information zu Schwachstellen und Sicherheitslücken
Titel: BeanShell: Eine Schwachstelle ermöglicht die Ausführung beliebigen Programmcodes
Datum: 08.03.2016
Software: BeanShell <= 2.0 beta 5
Plattform: Canonical Ubuntu Linux 12.04 Lts, Canonical Ubuntu Linux 14.04 Lts, Canonical Ubuntu Linux 15.10, Debian Linux 7.9 Wheezy, Debian Linux 8.3 Jessie, Debian Linux 9.0 Stretch
Auswirkung: Ausführen beliebigen Programmcodes
Remoteangriff: Ja
Risiko: niedrig
CVE Liste: CVE-2016-2510
Bezug: Debian Security Advisory DSA-3504-1
Beschreibung

BeanShell ist ein quelloffener, einbettbarer Java-Interpreter, der erweiterte Funktionen von objektorientierten Skriptsprachen bereitstellt.

Ein entfernter, nicht authentifizierter Angreifer kann speziell präparierte Daten in den Datenstrom zwischen Server und Klient einfügen, durch deren Deserialisierung die Ausführung beliebigen Programmcodes auch auf der Kommandozeile ermöglicht wird. Debian stellt für die Distributionen Wheezy (oldstable), Jessie (stable) und Stretch (testing) Backport-Sicherheitsupdates bereit, die diese Schwachstelle beheben. Update: Canonical stellt Backport-Sicherheitsupdates für die Distributionen Ubuntu 15.10, Ubuntu 14.04 LTS und Ubuntu 12.04 LTS zur Verfügung.

  1. Schwachstelle CVE-2016-2510 (NVD)

  2. Debian Security Advisory DSA-3504-1

  3. Ubuntu Security Notice USN-2923-1

CERT-Bund bietet personalisierte Warn- und Informationsdienste an.
Bitte registrieren Sie sich, um diese Angebote nutzen zu können.