Kurzinfo CB-K16/0358 Update 4

2 Risiko: niedrig
Information zu Schwachstellen und Sicherheitslücken
Titel: BeanShell: Eine Schwachstelle ermöglicht die Ausführung beliebigen Programmcodes
Datum: 17.03.2016
Software: BeanShell <= 2.0 beta 5
Plattform: SUSE Linux Enterprise Software Development Kit 11 SP4, SUSE Linux Enterprise Software Development Kit 12, SUSE Linux Enterprise Software Development Kit 12 SP1, Canonical Ubuntu Linux 12.04 Lts, Canonical Ubuntu Linux 14.04 Lts, Canonical Ubuntu Linux 15.10, Debian Linux 7.9 Wheezy, Debian Linux 8.3 Jessie, Debian Linux 9.0 Stretch, openSUSE Leap 42.1
Auswirkung: Ausführen beliebigen Programmcodes
Remoteangriff: Ja
Risiko: niedrig
CVE Liste: CVE-2016-2510
Bezug: Debian Security Advisory DSA-3504-1
Beschreibung

BeanShell ist ein quelloffener, einbettbarer Java-Interpreter, der erweiterte Funktionen von objektorientierten Skriptsprachen bereitstellt.

Ein entfernter, nicht authentifizierter Angreifer kann speziell präparierte Daten in den Datenstrom zwischen Server und Klient einfügen, durch deren Deserialisierung die Ausführung beliebigen Programmcodes auch auf der Kommandozeile ermöglicht wird. Debian stellt für die Distributionen Wheezy (oldstable), Jessie (stable) und Stretch (testing) Backport-Sicherheitsupdates bereit, die diese Schwachstelle beheben. Update: Für die Distribution openSUSE Leap 42.1 steht ein Sicherheitsupdate bereit.

  1. Schwachstelle CVE-2016-2510 (NVD)

  2. Debian Security Advisory DSA-3504-1

  3. Ubuntu Security Notice USN-2923-1

  4. SUSE Security Update SUSE-SU-2016:0699-1

  5. SUSE Security Update USE-SU-2016:0700-1

  6. openSUSE Security Update openSUSE-SU-2016:0788-1

CERT-Bund bietet personalisierte Warn- und Informationsdienste an.
Bitte registrieren Sie sich, um diese Angebote nutzen zu können.