Kurzinfo CB-K17/1351

4 Risiko: hoch
Information zu Schwachstellen und Sicherheitslücken
Titel: PostgreSQL: Mehrere Schwachstellen ermöglichen u.a. das Umgehen von Sicherheitsvorkehrungen
Datum: 11.08.2017
Software: PostgreSQL < 9.2.22, PostgreSQL < 9.3.18, PostgreSQL < 9.4.13, PostgreSQL < 9.5.8, PostgreSQL < 9.6.4
Plattform: Apple Mac OS X, macOS Sierra, FreeBSD, GNU/Linux, Microsoft Windows , OpenBSD, Oracle Solaris, Red Hat Fedora 26
Auswirkung: Umgehen von Sicherheitsvorkehrungen
Remoteangriff: Ja
Risiko: hoch
CVE Liste: CVE-2017-7546, CVE-2017-7547, CVE-2017-7548
Bezug: PostgreSQL Security Information
Revisions Historie
  • Version: 1

    Neues Advisory

Beschreibung

PostgreSQL ist ein freies, objektrelationales Datenbankmanagementsystem.

Eine Schwachstelle in PostgreSQL ermöglicht einem entfernten, nicht authentisierten Angreifer, sich ohne Passwort an betroffenen Systemen anzumelden und dadurch weitere Angriffe durchzuführen. Zwei weitere Schwachstellen ermöglichen einem entfernten, einfach authentisierten Angreifer die Eskalation seiner Privilegien, um dadurch möglicherweise sensitive Informationen auszuspähen und Daten zu manipulieren. Der Hersteller stellt die Versionen 9.6.4, 9.5.8, 9.4.13, 9.3.18 und 9.2.22 als Sicherheitsupdates bereit und kündigt an, dass der Versionszweig 9.2 ab September nicht weiter unterstützt wird (End-of-Life). Darüber hinaus weist der Hersteller darauf hin, dass der Patch für CVE-2017-7547 nur neu erstellte Cluster beeinflusst. Für bereits bestehende Cluster findet sich eine detaillierte Anleitung im Sicherheitshinweis. Für das MinGW-Projekt in Fedora 26 steht mit dem Paket 'mingw-postgresql-9.6.4-1.fc26' ein Sicherheitsupdate auf Version 9.6.4 im Status 'pending' bereit.

  1. PostgreSQL Security Information

  2. Fedora Security Update FEDORA-2017-f9e66916ec (Fedora 26, mingw-postgresql-9.6.4-1)

  3. PostgreSQL 9.6.4 Release Notes

  4. PostgreSQL 9.6.4, 9.5.8, 9.4.13, 9.3.18, 9.2.22 Release Notes

  5. Schwachstelle CVE-2017-7546 (NVD)

  6. Schwachstelle CVE-2017-7547 (NVD)

  7. Schwachstelle CVE-2017-7548 (NVD)

CERT-Bund bietet personalisierte Warn- und Informationsdienste an.
Bitte registrieren Sie sich, um diese Angebote nutzen zu können.