Kurzinfo CB-K17/1446 Update 4

2 Risiko: niedrig
Information zu Schwachstellen und Sicherheitslücken
Titel: OpenSSL: Zwei Schwachstellen ermöglichen das Darstellen falscher Informationen und das Ausspähen von Informationen
Datum: 10.11.2017
Software: OpenSSL Project OpenSSL < 1.0.2m, OpenSSL Project OpenSSL < 1.1.0g
Plattform: Apple Mac OS X, Canonical Ubuntu Linux 14.04 LTS, Canonical Ubuntu Linux 16.04 LTS, Canonical Ubuntu Linux 17.04, Canonical Ubuntu Linux 17.10, Debian Linux 8.9 Jessie, Debian Linux 9.2 Stretch, FreeBSD, GNU/Linux, HP-UX, Microsoft Windows , SUSE Linux Enterprise Server 11 SECURITY, Oracle Solaris
Auswirkung: Darstellen falscher Informationen
Remoteangriff: Ja
Risiko: niedrig
CVE Liste: CVE-2017-3735, CVE-2017-3736
Bezug: Pull-Request #4276: Avoid out-of-bounds read
Revisions Historie
  • Version: 5

    Für SUSE Linux Enterprise Server 11 SECURITY steht ein Sicherheitsupdate für 'openssl1' zur Verfügung, mit dem die Schwachstelle CVE-2017-3735 und weitere sicherheitsrelevante Programmfehler behoben werden.

  • Version: 4

    Canonical stellt für die aktuellen Distributionen Ubuntu Linux 14.04 LTS, 16.04 LTS, 17.04 und 17.10 Backport-Sicherheitsupdates zur Behebung der beiden Schwachstellen in OpenSSL bereit.

  • Version: 3

    Debian stellt für die stabile Distribution Stretch Backport-Sicherheitsupdates für OpenSSL 1.1.0 und 1.0.2 zur Verfügung, um beide Schwachstellen zu beheben. Außerdem steht ein Backport-Sicherheitsupdate für OpenSSL 1.0.1 für die alte stabile Distribution Jessie bereit. Die Distribution Jessie war nur von der Schwachstelle CVE-2017-3735, jedoch nicht von CVE-2017-3736 betroffen.

  • Version: 2

    Der Hersteller hat mit OpenSSL Security Advisory [02 Nov 2017] nun Sicherheitsupdates für die unterstützten Versionszweige veröffentlicht und informiert zusätzlich über die Schwachstelle CVE-2017-3736, welche einem entfernten, nicht authentisierter Angreifer, der Online-Zugriff auf ein angreifbares System hat, ermöglicht, private Schlüssel zu ermitteln und damit sensible Informationen auszuspähen. Benutzer von OpenSSL 1.1.0 sollten auf die neue Version 1.1.0g und Benutzer von OpenSSL 1.0.2 auf die neue Version 1.0.2m aktualisieren, um gegen beide Schwachstellen geschützt zu sein.

  • Version: 1

    Neues Advisory

Beschreibung

OpenSSL ist eine freie Software, die kryptographische Funktionen und Protokolle implementiert. Bestandteil ist auch das TLS-Protokoll (Transport Layer Security). Es wurde ursprünglich als Secure Socket Layer entwickelt und ist immer noch unter dem Namen SSL bekannt.

Ein entfernter, nicht authentisierter Angreifer kann eine Schwachstelle in OpenSSL ausnutzen, um falsche Informationen in der Textansicht eines X.509-Zertifikats darzustellen. Da die Herkunft der Informationen in einem nicht dafür vorgesehenen Speicherbereich liegt, lassen sich dadurch möglicherweise auch Informationen ausspähen. Der Hersteller informiert über die Schwachstelle in allen Versionen von OpenSSL seit 2006 und stellt über das Quellcode-Repository einen Patch bereit (siehe Referenz 'Pull-Request #4276'). Aufgrund des geringen Schweregrades der Schwachstelle verzichtet der Hersteller in diesem Fall auf ein eigenständiges Release zur Behebung der Schwachstelle.

  1. Pull-Request #4276: Avoid out-of-bounds read

  2. OpenSSL Security Advisory [28 Aug 2017]

  3. Schwachstelle CVE-2017-3735 (NVD)

  4. OpenSSL Security Advisory [02 Nov 2017]

  5. Schwachstelle CVE-2017-3736 (NVD)

  6. Debian Security Advisory DSA-4017-1

  7. Debian Security Advisory DSA-4018-1

  8. Ubuntu Security Notice USN-3475-1

  9. SUSE Security Update SUSE-SU-2017:2968-1

CERT-Bund bietet personalisierte Warn- und Informationsdienste an.
Bitte registrieren Sie sich, um diese Angebote nutzen zu können.